Plugins Database As of 12-10-2019

PostgreSQL 9.4.x < 9.4.22, 9.5.x < 9.5.17, 9.6.x < 9.6.13, 10.x < 10.8, 11.x < 11.3 Code Execution Vulnerability (Windows)

Impact by CVSS Score
  • ID:

CVSS Base Vector:

Detection Type:
Remote Banner Unreliable

Solution Type:
Vendor Patch

PostgreSQL is prone to an arbitrary code execution vulnerability due to BigSQL and EnterpriseDB Windows installer not clearing permissive ACL entries.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
Due to both the EnterpriseDB and BigSQL Windows installers not locking down the permissions of the PostgreSQL binary installation directory and the data directory, an unprivileged Windows user account and an unprivileged PostgreSQL account could cause the PostgreSQL service account to execute arbitrary code. This vulnerability is present in all supported versions of PostgreSQL for these installers, and possibly exists in older versions. Both sets of installers have fixed the permissions for these directories for both new and existing installations. If you have installed PostgreSQL on Windows using other methods, we advise that you check that your PostgreSQL binary directories are writable only to trusted users and that your data directories are only accessible to trusted users.

Affected Versions:
PostgreSQL versions 9.4.x, 9.5.x, 9.6.x, 10.x and 11.x installed on Windows via BigSQL or EnterpriseDB installer.

Update to version 9.4.22, 9.5.17, 9.6.13, 10.8, 11.3 or later.

CVSS Score
2019-08-01 07:53:57
2019-08-01 08:03:52

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.