CVSS Base Vector:
Remote Banner Unreliable
PostgreSQL is prone to an arbitrary code execution vulnerability due to
BigSQL and EnterpriseDB Windows installer not clearing permissive ACL entries.
Checks if a vulnerable version is present on the target host.
Due to both the EnterpriseDB and BigSQL Windows installers not locking down
the permissions of the PostgreSQL binary installation directory and the data directory, an unprivileged Windows
user account and an unprivileged PostgreSQL account could cause the PostgreSQL service account to execute arbitrary code.
This vulnerability is present in all supported versions of PostgreSQL for these installers, and possibly exists
in older versions. Both sets of installers have fixed the permissions for these directories for both new and existing
installations. If you have installed PostgreSQL on Windows using other methods, we advise that you check that your
PostgreSQL binary directories are writable only to trusted users and that your data directories are only accessible
to trusted users.
PostgreSQL versions 9.4.x, 9.5.x, 9.6.x, 10.x and 11.x installed on Windows via
BigSQL or EnterpriseDB installer.
Update to version 9.4.22, 9.5.17, 9.6.13, 10.8, 11.3 or later.