WordPress GiveWP Plugin < 2.4.7 XSS Vulnerability

Technical Details

Severity Level:

Low Severity

CVSS Score:

3.5

CVSS Base Vector:
AV:N/AC:M/Au:S/C:N/I:P/A:N

Detection Type:
Remote Banner

Solution Type:
Vendor Patch

Summary:
The WordPress plugin GiveWP is prone to a cross-site scripting (XSS) vulnerability.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
The vulnerability is exploitable via a donor name.

Impact:
Successful exploitation would allow an authenticated attacker to inject arbitrary HTML and JavaScript into the site.

Affected Versions:
WordPress GiveWP plugin through version 2.4.6.

Recommendations:
Update to version 2.4.7 or later.

Family:

Web application abuses

Creation Time:

2019-09-16 13:31:28

Modification Time:

2019-09-16 11:38:53

Find and Fix this Vulnerability:

Mageni can help you to find out if you have this or more vulnerabilities exposing you to hackers, ransomware and malware: Download Mageni's Free Edition

NVD CVE ID:
CVE-2019-15317

Don't pay for a vulnerability scanning and management platform. This one is free.

Mageni provides a free vulnerability scanning and management platform which helps you need to find, prioritize, remediate and manage your vulnerabilities.