OpenEMR <= 5.0.2 Multiple Vulnerabilities

Technical Details

Severity Level:

High Severity

CVSS Score:

7.5

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Detection Type:
Remote Banner

Solution Type:
None Available

Summary:
OpenEMR is prone to multiple vulnerabilities.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
The following vulnerabilities exist: - There is an XSS vulnerability in library/custom_template/add_template.php via a crafted list_id query parameter. - There is an SQL Injection vulnerability in the Lifestyle demographic filter criteria in library/clinical_rules.php that affects library/patient.inc.

Impact:
Successful exploitation would allow an attacker to inject arbitrary HTML or JavaScript into the site, read sensitive information or execute arbitrary code on the target machine.

Affected Versions:
OpenEMR through version 5.0.2.

Recommendations:
No known solution is available as of 09th October, 2019. Information regarding this issue will be updated once solution details are available.

Family:

Web application abuses

Creation Time:

2019-10-09 13:12:41

Modification Time:

2019-10-09 11:18:34

Find and Fix this Vulnerability:

Mageni can help you to find out if you have this or more vulnerabilities exposing you to hackers, ransomware and malware: Download Mageni's Free Edition

NVD CVE ID:
CVE-2019-17179
CVE-2019-17197

Don't pay for a vulnerability scanning and management platform. This one is free.

Mageni provides a free vulnerability scanning and management platform which helps you need to find, prioritize, remediate and manage your vulnerabilities.