Elasticsearch Logstash Beats Input Plugin DoS Vulnerability (ESA-2019-14)

Technical Details

Severity Level:

Medium Severity

CVSS Score:

5.0

CVSS Base Vector:
AV:N/AC:L/Au:N/C:N/I:N/A:P

Detection Type:
Remote Banner Unreliable

Solution Type:
Vendor Patch

Summary:
A denial of service flaw was found in the Logstash beats input plugin.

Impact:
An unauthenticated user who is able to connect to the port the Logstash beats input could send a specially crafted network packet that would cause Logstash to stop responding.

Detection Method:
Checks if a vulnerable version is present on the target host.

Affected Versions:
Logstash versions before 6.8.4 and 7.4.1.

Recommendations:
Update to version 6.8.4, 7.4.1 or later.

Family:

Denial of Service

Creation Time:

2019-11-05 03:04:11

Modification Time:

2019-11-05 03:10:23

Find and Fix this Vulnerability:

Mageni can help you to find out if you have this or more vulnerabilities exposing you to hackers, ransomware and malware: Download Mageni's Free Edition

NVD CVE ID:
CVE-2019-7620

Don't pay for a vulnerability scanning and management platform. This one is free.

Mageni provides a free vulnerability scanning and management platform which helps you need to find, prioritize, remediate and manage your vulnerabilities.