Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2001-1384

CVE information

Published

20 years ago

Last Modified

5 years ago

CVSSv2.0 Severity

High

Impact Analysis

Description

ptrace in Linux 2.2.x through 2.2.19, and 2.4.x through 2.4.9, allows local users to gain root privileges by running ptrace on a setuid or setgid program that itself calls an unprivileged program, such as newgrp..

CVSSv2.0 Score

Severity
High
Base Score
7.2/10
Exploit Score
3.9/10
Access Vector
Local
Access Complexity
Low
Authentication Required
None
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:o:linux:linux_kernel:2.2.10:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.13:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.18:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.4.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.17:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.15:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.16:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.4.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.4.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.11:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.12:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.19:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.4.10:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.4.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.14:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.2.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:linux:linux_kernel:2.4.3:*:*:*:*:*:*:*
  Yes
- -