Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2011-2686

CVE information

Published

11 years ago

Last Modified

4 years ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

Ruby before 1.8.7-p352 does not reset the random seed upon forking, which makes it easier for context-dependent attackers to predict the values of random numbers by leveraging knowledge of the number sequence obtained in a different child process, a related issue to CVE-2003-0900. NOTE: this issue exists because of a regression during Ruby 1.8.6 development..

CVSSv2.0 Score

Severity
Medium
Base Score
5/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
2.9/10
Confidentiality Impact
Partial
Availability Impact
None
Integrity Impact
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:ruby-lang:ruby:1.8.7-302:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ruby-lang:ruby:1.8.7-249:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ruby-lang:ruby:1.8.7-299:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ruby-lang:ruby:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ruby-lang:ruby:1.8.7:p71:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ruby-lang:ruby:1.8.7:p22:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ruby-lang:ruby:1.8.7-330:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ruby-lang:ruby:1.8.7-160:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ruby-lang:ruby:1.8.7-173:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ruby-lang:ruby:1.8.7-p21:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ruby-lang:ruby:1.8.7-248:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:ruby-lang:ruby:1.8.7:p72:*:*:*:*:*:*
  Yes
- -