Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2004-0077

CVE information

Published

18 years ago

Last Modified

4 years ago

CVSSv2.0 Severity

High

Impact Analysis

Description

The do_mremap function for the mremap system call in Linux 2.2 to 2.2.25, 2.4 to 2.4.24, and 2.6 to 2.6.2, does not properly check the return value from the do_munmap function when the maximum number of VMA descriptors is exceeded, which allows local users to gain root privileges, a different vulnerability than CAN-2003-0985..

CVSSv2.0 Score

Severity
High
Base Score
7.2/10
Exploit Score
3.9/10
Access Vector
Local
Access Complexity
Low
Authentication Required
None
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:redhat:kernel_doc:2.4.20-8:*:i386:*:*:*:*:*
  Yes
- -
cpe:2.3:a:redhat:kernel:2.4.20-8:*:athlon_smp:*:*:*:*:*
  Yes
- -
cpe:2.3:a:redhat:bigmem_kernel:2.4.20-8:*:i686:*:*:*:*:*
  Yes
- -
cpe:2.3:a:redhat:kernel:2.4.20-8:*:i686_smp:*:*:*:*:*
  Yes
- -
cpe:2.3:a:redhat:kernel:2.4.20-8:*:i386:*:*:*:*:*
  Yes
- -

References