CVE-2004-0234 Details

CVE-2004-0234

Published: 2004-08-18
Last Modified: 2017-10-11
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

Multiple stack-based buffer overflows in the get_header function in header.c for LHA 1.14, as used in products such as Barracuda Spam Firewall, allow remote attackers or local users to execute arbitrary code via long directory or file names in an LHA archive, which triggers the overflow when testing or extracting the archive.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 10/10
Exploit Score 10/10
Access Vector Network
Access Complexity Low
Authentication None
Impact Score 10/10
Confidentiality Impact Complete
Availability Impact Complete
Integrity Impact Complete
Vector String AV:N/AC:L/Au:N/C:C/I:C/A:C
Common Vulnerability Score System v3.1

NIST has not assigned a CVSSv3.1 Score.

Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:clearswift:mailsweeper:4.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.3.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.3.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:4.51:*:linux_servers: Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:4.51:*:linux_workstat Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:5.41:*:workstations:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:5.42:*:mimesweeper:*: Yes - -
cpe:2.3:a:f-secure:f-secure_internet_security:2003:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_internet_security:2004:*:*:*:*:* Yes - -
cpe:2.3:a:sgi:propack:2.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:sgi:propack:3.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.3.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:5.42:*:workstations:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:5.42:*:windows_server Yes - -
cpe:2.3:a:f-secure:internet_gatekeeper:6.32:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:5.5:*:client_security Yes - -
cpe:2.3:a:f-secure:f-secure_personal_express:4.6:*:*:*:*:*:* Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:4.52:*:linux_gateways Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.3.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_personal_express:4.7:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:4.52:*:linux_servers: Yes - -
cpe:2.3:a:f-secure:f-secure_personal_express:4.5:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:5.52:*:client_securit Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:4.52:*:linux_workstat Yes - -
cpe:2.3:a:tsugio_okamoto:lha:1.14:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.3.11:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:2003:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:stalker:cgpmcafee:3.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:internet_gatekeeper:6.31:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:4.60:*:samba_servers: Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.3.6_sp1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.3.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.3.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:tsugio_okamoto:lha:1.17:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:5.41:*:windows_server Yes - -
cpe:2.3:a:rarlab:winrar:3.20:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:5.41:*:mimesweeper:*: Yes - -
cpe:2.3:a:f-secure:f-secure_for_firewalls:6.20:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:tsugio_okamoto:lha:1.15:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:4.51:*:linux_gateways Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:2004:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:winzip:winzip:9.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.3.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:f-secure:f-secure_anti-virus:6.21:*:ms_exchange:*: Yes - -
cpe:2.3:a:clearswift:mailsweeper:4.3.13:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:redhat:lha:1.14i-9:*:i386:*:*:*:*:* Yes - -
cpe:2.3:o:redhat:fedora_core:core_1.0:*:*:*:*:*:*:* Yes - -
References

http://www.securityfocus.com/bid/10243
http://lists.grok.org.uk/pipermail/full-disclosure/2004-May/020776.html
http://lists.grok.org.uk/pipermail/full-disclosure/2004-May/020778.html
http://www.debian.org/security/2004/dsa-515
http://www.redhat.com/support/errata/RHSA-2004-178.html
http://www.redhat.com/support/errata/RHSA-2004-179.html
http://security.gentoo.org/glsa/glsa-200405-02.xml
http://www.redhat.com/archives/fedora-announce-list/2004-May/msg00005.html
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000840
http://archives.neohapsis.com/archives/bugtraq/2006-04/0059.html
http://www.guay-leroux.com/projects/barracuda-advisory-LHA.txt
http://www.osvdb.org/5753
http://www.osvdb.org/5754
http://securitytracker.com/id?1015866
http://secunia.com/advisories/19514
http://www.vupen.com/english/advisories/2006/1220
https://bugzilla.fedora.us/show_bug.cgi?id=1833
http://marc.info/?l=bugtraq&m=108422737918885&w=2
https://exchange.xforce.ibmcloud.com/vulnerabilities/16012
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9

CVE ID
CVE-2004-0234
Published
2004-08-18
Modified
2017-10-11
CVSSv2.0
High
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-119

Free Vulnerability Scanning, Assessment and Management

Mageni's Platform is packed with all the features you need to scan, assess and manage vulnerabilities like this - it is free, open source, lightning fast, reliable and scalable.

Router
Servers
Laptop
Database
Group
Cloud

Frequently Asked Questions

No, you can scan concurrently as many assets as you want. Please note that you must be aware of the hardware requeriments of the platform to ensure a good performance.

No, you can add as many assest as you want. It doesn't matters if you have millions of assets, we won't charge you for that.

No. The software is completely free. We have no intention to charge you to use the software, in fact - it completely goes against our beliefs and business model.

A vulnerability is defined in the ISO 27002 standard as “A weakness of an asset or group of assets that can be exploited by one or more threats” (International Organization for Standardization, 2005)

We generate revenue by providing support and other services for customers that require a subscription so they get guaranteed support and enterprise services. To use Mageni's Platform is completely free, with no limits at all.

Yes. Mageni understands that there are professionals and businesses that need commercial support so Mageni provides an active support subscription with everything needed to run Mageni's Platform reliably and securely. More than software, it's access to security experts, knowledge resources, security updates, and support tools you can't get anywhere else. The subscription includes:

  • Ongoing delivery
    • Patches
    • Bug fixes
    • Updates
    • Upgrades
  • Technical support
    • 24/7 availability
    • Unlimited Incidents
    • Specialty-based routing
    • Multi-Channel
  • Commitments
    • Software certifications
    • Software assurance
    • SLA

No, we don't store the information of your vulnerabilities in our servers.

Vulnerability management is the process in which vulnerabilities in IT are identified and the risks of these vulnerabilities are evaluated. This evaluation leads to correcting the vulnerabilities and removing the risk or a formal risk acceptance by the management of an organization. The term vulnerability management is often confused with vulnerability scanning. Despite the fact both are related, there is an important difference between the two. Vulnerability scanning consists of using a computer program to identify vulnerabilities in networks, computer infrastructure or applications. Vulnerability management is the process surrounding vulnerability scanning, also taking into account other aspects such as risk acceptance, remediation etc. Source: "Implementing a Vulnerability Management Process". SANS Institute.

I am ready to start scanning for vulnerabilities