CVE-2004-0414 Details

CVE-2004-0414

Published: 2004-08-06
Last Modified: 2018-05-03
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

CVS 1.12.x through 1.12.8, and 1.11.x through 1.11.16, does not properly handle malformed "Entry" lines, which prevents a NULL terminator from being used and may lead to a denial of service (crash), modification of critical program data, or arbitrary code execution.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 10/10
Exploit Score 10/10
Access Vector Network
Access Complexity Low
Authentication None
Impact Score 10/10
Confidentiality Impact Complete
Availability Impact Complete
Integrity Impact Complete
Vector String AV:N/AC:L/Au:N/C:C/I:C/A:C
Common Vulnerability Score System v3.1

NIST has not assigned a CVSSv3.1 Score.

Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:cvs:cvs:1.10.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.10.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.1_p1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.11:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.14:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.15:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.11.16:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.12.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.12.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.12.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.12.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:cvs:cvs:1.12.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:openpkg:openpkg:*:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:openpkg:openpkg:1.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:openpkg:openpkg:2.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:sgi:propack:2.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:sgi:propack:3.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:gentoo:linux:1.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:openbsd:openbsd:*:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:openbsd:openbsd:3.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:openbsd:openbsd:3.5:*:*:*:*:*:*:* Yes - -
References

ftp://patches.sgi.com/support/free/security/advisories/20040604-01-U.asc
ftp://patches.sgi.com/support/free/security/advisories/20040605-01-U.asc
http://lists.grok.org.uk/pipermail/full-disclosure/2004-June/022441.html
http://marc.info/?l=bugtraq&m=108716553923643&w=2
http://security.e-matters.de/advisories/092004.html
http://security.gentoo.org/glsa/glsa-200406-06.xml
http://www.debian.org/security/2004/dsa-517
http://www.mandriva.com/security/advisories?name=MDKSA-2004:058
http://www.redhat.com/support/errata/RHSA-2004-233.html
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10575
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A993

CVE ID
CVE-2004-0414
Published
2004-08-06
Modified
2018-05-03
CVSSv2.0
High
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE Pending

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.