Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2004-1065

CVE information

Published

17 years ago

Last Modified

3 years ago

CVSSv2.0 Severity

High

Impact Analysis

Description

Buffer overflow in the exif_read_data function in PHP before 4.3.10 and PHP 5.x up to 5.0.2 allows remote attackers to execute arbitrary code via a long section name in an image file..

CVSSv2.0 Score

Severity
High
Base Score
10/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:php:php:4.3.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.11:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.2.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.1.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openpkg:openpkg:2.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.13:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.17:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.3:patch1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.3.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.7:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.2.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.3.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.0:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.3.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.7:rc2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.3.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.3.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.12:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.16:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.3.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.0.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.1:patch1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.1:patch2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.2.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.3.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.0:rc2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.10:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.18:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.1.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.2.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.3.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openpkg:openpkg:2.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openpkg:openpkg:current:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.14:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:3.0.15:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.0.7:rc3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.2:*:dev:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:4.3.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:php:php:5.0:rc3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:trustix:secure_linux:2.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:ubuntu:ubuntu_linux:4.1:*:ppc:*:*:*:*:*
  Yes
- -
cpe:2.3:o:trustix:secure_linux:2.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:trustix:secure_linux:2.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:ubuntu:ubuntu_linux:4.1:*:ia64:*:*:*:*:*
  Yes
- -