Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2007-0017

CVE information

Published

15 years ago

Last Modified

4 years ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

Multiple format string vulnerabilities in (1) the cdio_log_handler function in modules/access/cdda/access.c in the CDDA (libcdda_plugin) plugin, and the (2) cdio_log_handler and (3) vcd_log_handler functions in modules/access/vcdx/access.c in the VCDX (libvcdx_plugin) plugin, in VideoLAN VLC 0.7.0 through 0.8.6 allow user-assisted remote attackers to execute arbitrary code via format string specifiers in an invalid URI, as demonstrated by a udp://-- URI in an M3U file..

CVSSv2.0 Score

Severity
Medium
Base Score
6.8/10
Exploit Score
8.6/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
None
Impact Score
6.4/10
Confidentiality Impact
Partial
Availability Impact
Partial
Integrity Impact
Partial

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:videolan:vlc_media_player:0.7.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:videolan:vlc_media_player:0.8.4a:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:videolan:vlc_media_player:0.8.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:videolan:vlc_media_player:0.8.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:videolan:vlc_media_player:0.8.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:videolan:vlc_media_player:0.8.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:videolan:vlc_media_player:0.7.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:videolan:vlc_media_player:0.8.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:videolan:vlc_media_player:0.7.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:videolan:vlc_media_player:0.8.2:*:*:*:*:*:*:*
  Yes
- -