Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2007-0646

CVE information

Published

16 years ago

Last Modified

11 years ago

CVSSv2.0 Severity

High

Impact Analysis

Description

Format string vulnerability in iMovie HD 6.0.3, and Safari in Apple Mac OS X 10.4 through 10.4.10, allows remote user-assisted attackers to cause a denial of service (crash) via format string specifiers in a filename, which is not properly handled when calling the NSRunCriticalAlertPanel Apple AppKit function..

CVSSv2.0 Score

Severity
High
Base Score
7.1/10
Exploit Score
8.6/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
None
Impact Score
6.9/10
Confidentiality Impact
None
Availability Impact
Complete
Integrity Impact
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:o:apple:mac_os_x:10.4:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:apple:mac_os_x:10.4.1:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:apple:mac_os_x:10.4.2:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:apple:mac_os_x:10.4.3:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:apple:mac_os_x:10.4.4:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:apple:mac_os_x:10.4.5:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:apple:mac_os_x:10.4.6:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:apple:mac_os_x:10.4.7:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:apple:mac_os_x:10.4.8:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:apple:mac_os_x:10.4.9:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:apple:mac_os_x:10.4.10:*:*:*:*:*:*:*
  No
-
cpe:2.3:a:apple:imovie:6.0.3:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:a:apple:safari:*:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:o:apple:mac_os_x:10.3.9:*:*:*:*:*:*:*
  Yes
-