Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2008-0047

CVE information

Published

14 years ago

Last Modified

5 years ago

CVSSv2.0 Severity

High

Impact Analysis

Description

Heap-based buffer overflow in the cgiCompileSearch function in CUPS 1.3.5, and other versions including the version bundled with Apple Mac OS X 10.5.2, when printer sharing is enabled, allows remote attackers to execute arbitrary code via crafted search expressions..

CVSSv2.0 Score

Severity
High
Base Score
9.3/10
Exploit Score
8.6/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
None
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:o:apple:mac_os_x_server:10.5.2:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:apple:mac_os_x:10.5.2:*:*:*:*:*:*:*
  No
-
cpe:2.3:a:cups:cups:1.3.5:*:*:*:*:*:*:*
  Yes
-