Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2008-0166

CVE information

Published

14 years ago

Last Modified

11 months ago

CVSSv2.0 Severity

High

Impact Analysis

Description

OpenSSL 0.9.8c-1 up to versions before 0.9.8g-9 on Debian-based operating systems uses a random number generator that generates predictable numbers, which makes it easier for remote attackers to conduct brute force guessing attacks against cryptographic keys..

CVSSv2.0 Score

Severity
High
Base Score
7.8/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
6.9/10
Confidentiality Impact
Complete
Availability Impact
None
Integrity Impact
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:openssl:openssl:0.9.8c-1:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:a:openssl:openssl:0.9.8d:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:a:openssl:openssl:0.9.8e:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:a:openssl:openssl:0.9.8f:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:a:openssl:openssl:0.9.8g:*:*:*:*:*:*:*
  Yes
-
cpe:2.3:o:canonical:ubuntu_linux:7.04:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:canonical:ubuntu_linux:7.10:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:canonical:ubuntu_linux:8.04:*:*:*:*:*:*:*
  No
-
cpe:2.3:o:debian:debian_linux:4.0:*:*:*:*:*:*:*
  No
-