Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2009-0510

CVE information

Published

13 years ago

Last Modified

12 years ago

CVSSv2.0 Severity

High

Impact Analysis

Description

Heap-based buffer overflow in the JBIG2 filter in Adobe Reader 7 and Acrobat 7 before 7.1.3, Adobe Reader 8 and Acrobat 8 before 8.1.6, and Adobe Reader 9 and Acrobat 9 before 9.1.2 might allow remote attackers to execute arbitrary code via unspecified vectors, a different vulnerability than CVE-2009-0511, CVE-2009-0512, CVE-2009-0888, and CVE-2009-0889..

CVSSv2.0 Score

Severity
High
Base Score
9.3/10
Exploit Score
8.6/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
None
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:adobe:acrobat_reader:9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.0.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.6:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.1:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.4:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.1:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.1.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:9.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.0.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:9.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.4:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.5:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.1:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.0:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.2:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.5:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:9.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.9:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.4:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.7:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.3:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.0:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:8.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.0.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.8:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:8.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.1.1:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:8.1.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:8.1.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.1:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.3:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.6:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:9.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:9.1:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.1:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:8.1.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:8.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.2:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.2:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.8:*:elements:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.2:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:8.1.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.1:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.4:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.7:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:9.0.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:8.1.2:security_update:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.3:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.3:*:professional:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.8:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:9.0:*:standard:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.2:security_update:professional:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:7.0.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat:8.1.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:adobe:acrobat_reader:7.0.4:*:*:*:*:*:*:*
  Yes
- -