CVE-2009-0583 Details

CVE-2009-0583

Published: 2009-03-23
Last Modified: 2018-10-10
CVE Author: NIST National Vulnerability Database
CVE Assigner: secalert@redhat.com
Summary

Multiple integer overflows in icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allow context-dependent attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly execute arbitrary code by using a device file for a translation request that operates on a crafted image file and targets a certain "native color space," related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 9.3/10
Exploit Score 8.6/10
Access Vector Network
Access Complexity Medium
Authentication None
Impact Score 10/10
Confidentiality Impact Complete
Availability Impact Complete
Integrity Impact Complete
Vector String AV:N/AC:M/Au:N/C:C/I:C/A:C
Common Vulnerability Score System v3.1

NIST has not assigned a CVSSv3.1 Score.

Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:ghostscript:ghostscript:8.63:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:8.57:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:8.0.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:8.15:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:*:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:8.15.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:7.07:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:8.56:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:8.54:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:8.61:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:8.62:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:7.05:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ghostscript:ghostscript:5.50:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:argyllcms:argyllcms:*:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:argyllcms:argyllcms:1.0.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:argyllcms:argyllcms:0.7.0:beta_8:*:*:*:*:*:* Yes - -
cpe:2.3:a:argyllcms:argyllcms:0.2.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:argyllcms:argyllcms:0.2.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:argyllcms:argyllcms:1.0.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:argyllcms:argyllcms:0.3.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:argyllcms:argyllcms:0.6.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:argyllcms:argyllcms:0.2.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:argyllcms:argyllcms:0.1.0:*:*:*:*:*:*:* Yes - -
References

http://secunia.com/advisories/34393
https://bugzilla.redhat.com/show_bug.cgi?id=487742
http://www.redhat.com/support/errata/RHSA-2009-0345.html
http://wiki.rpath.com/wiki/Advisories:rPSA-2009-0050
http://securitytracker.com/id?1021868
https://issues.rpath.com/browse/RPL-2991
http://www.vupen.com/english/advisories/2009/0776
https://www.redhat.com/archives/fedora-package-announce/2009-March/msg00770.html
http://secunia.com/advisories/34373
http://secunia.com/advisories/34398
http://www.debian.org/security/2009/dsa-1746
https://www.redhat.com/archives/fedora-package-announce/2009-March/msg00772.html
http://www.vupen.com/english/advisories/2009/0777
http://secunia.com/advisories/34381
http://bugs.gentoo.org/show_bug.cgi?id=261087
http://www.auscert.org.au/render.html?it=10666
http://www.securityfocus.com/bid/34184
http://www.gentoo.org/security/en/glsa/glsa-200903-37.xml
http://support.avaya.com/elmodocs2/security/ASA-2009-098.htm
http://secunia.com/advisories/34437
http://www.vupen.com/english/advisories/2009/0816
http://www.ubuntu.com/usn/USN-743-1
http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00004.html
http://secunia.com/advisories/34418
http://secunia.com/advisories/34266
https://www.redhat.com/archives/fedora-package-announce/2009-March/msg00916.html
http://secunia.com/advisories/34469
https://www.redhat.com/archives/fedora-package-announce/2009-March/msg00887.html
http://secunia.com/advisories/34443
http://secunia.com/advisories/34729
http://www.mandriva.com/security/advisories?name=MDVSA-2009:095
http://www.mandriva.com/security/advisories?name=MDVSA-2009:096
http://sunsolve.sun.com/search/document.do?assetkey=1-26-262288-1
http://www.vupen.com/english/advisories/2009/1708
http://secunia.com/advisories/35569
http://secunia.com/advisories/35559
https://exchange.xforce.ibmcloud.com/vulnerabilities/49329
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A1
https://usn.ubuntu.com/757-1/
http://www.securityfocus.com/archive/1/501994/100/0/threaded

CVE ID
CVE-2009-0583
Published
2009-03-23
Modified
2018-10-10
CVSSv2.0
High
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-119

Free Vulnerability Scanning, Assessment and Management

Mageni's Platform is packed with all the features you need to scan, assess and manage vulnerabilities like this - it is free, open source, lightning fast, reliable and scalable.

Router
Servers
Laptop
Database
Group
Cloud

Frequently Asked Questions

No, you can scan concurrently as many assets as you want. Please note that you must be aware of the hardware requeriments of the platform to ensure a good performance.

No, you can add as many assest as you want. It doesn't matters if you have millions of assets, we won't charge you for that.

No. The software is completely free. We have no intention to charge you to use the software, in fact - it completely goes against our beliefs and business model.

A vulnerability is defined in the ISO 27002 standard as “A weakness of an asset or group of assets that can be exploited by one or more threats” (International Organization for Standardization, 2005)

We generate revenue by providing support and other services for customers that require a subscription so they get guaranteed support and enterprise services. To use Mageni's Platform is completely free, with no limits at all.

Yes. Mageni understands that there are professionals and businesses that need commercial support so Mageni provides an active support subscription with everything needed to run Mageni's Platform reliably and securely. More than software, it's access to security experts, knowledge resources, security updates, and support tools you can't get anywhere else. The subscription includes:

  • Ongoing delivery
    • Patches
    • Bug fixes
    • Updates
    • Upgrades
  • Technical support
    • 24/7 availability
    • Unlimited Incidents
    • Specialty-based routing
    • Multi-Channel
  • Commitments
    • Software certifications
    • Software assurance
    • SLA

No, we don't store the information of your vulnerabilities in our servers.

Vulnerability management is the process in which vulnerabilities in IT are identified and the risks of these vulnerabilities are evaluated. This evaluation leads to correcting the vulnerabilities and removing the risk or a formal risk acceptance by the management of an organization. The term vulnerability management is often confused with vulnerability scanning. Despite the fact both are related, there is an important difference between the two. Vulnerability scanning consists of using a computer program to identify vulnerabilities in networks, computer infrastructure or applications. Vulnerability management is the process surrounding vulnerability scanning, also taking into account other aspects such as risk acceptance, remediation etc. Source: "Implementing a Vulnerability Management Process". SANS Institute.

I am ready to start scanning for vulnerabilities