Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2009-0756

CVE information

Published

13 years ago

Last Modified

4 years ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

The JBIG2Stream::readSymbolDictSeg function in Poppler before 0.10.4 allows remote attackers to cause a denial of service (crash) via a PDF file that triggers a parsing error, which is not properly handled by JBIG2SymbolDict::~JBIG2SymbolDict and triggers an invalid memory dereference..

CVSSv2.0 Score

Severity
Medium
Base Score
5/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
Partial
Integrity Impact
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:poppler:poppler:0.7.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.3.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.4.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.10.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.7.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.6.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.3.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.5.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.5.91:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.4.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.5.90:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.5.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.7.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.5.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.4.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.6.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.2.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.7.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.6.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.3.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.6.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.1.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.8.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.4.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.5.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.5.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.4.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.3.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.5.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.6.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:poppler:poppler:0.10.2:*:*:*:*:*:*:*
  Yes
- -