Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2009-0839

CVE information

Published

13 years ago

Last Modified

1 year ago

CVSSv2.0 Severity

High

Impact Analysis

Description

Stack-based buffer overflow in mapserv.c in mapserv in MapServer 4.x before 4.10.4 and 5.x before 5.2.2, when the server has a map with a long IMAGEPATH or NAME attribute, allows remote attackers to execute arbitrary code via a crafted id parameter in a query action..

CVSSv2.0 Score

Severity
High
Base Score
10/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:umn:mapserver:4.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:umn:mapserver:4.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:umn:mapserver:4.0:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.2.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.4.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.4.0:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.6.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.6.0:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.6.0:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.10.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.10.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.8.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.8.0:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.0.0:beta6:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.0.0:beta5:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.10.0:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.10.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.8.0:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.0.0:beta4:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.0.0:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.10.0:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.10.0:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.0.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.10.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.10.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.8.0:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.8.0:rc2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.2.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.2.0:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.6.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.4.0:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.4.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.2.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.2.0:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:4.6.0:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.2.0:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.0.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.0.0:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.2.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.0.0:rc2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.0.0:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:osgeo:mapserver:5.2.0:beta4:*:*:*:*:*:*
  Yes
- -