Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2009-0871

CVE information

Published

13 years ago

Last Modified

4 years ago

CVSSv2.0 Severity

Low

Impact Analysis

Description

The SIP channel driver in Asterisk Open Source 1.4.22, 1.4.23, and 1.4.23.1; 1.6.0 before 1.6.0.6; 1.6.1 before 1.6.1.0-rc2; and Asterisk Business Edition C.2.3, with the pedantic option enabled, allows remote authenticated users to cause a denial of service (crash) via a SIP INVITE request without any headers, which triggers a NULL pointer dereference in the (1) sip_uri_headers_cmp and (2) sip_uri_params_cmp functions..

CVSSv2.0 Score

Severity
Low
Base Score
3.5/10
Exploit Score
6.8/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
Single
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
Partial
Integrity Impact
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:digium:asterisk:1.6.0:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.1:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:beta4:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:beta8:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:beta9:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:c.2.3:-:business:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.1:beta4:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0.3:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.1:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.4.22:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:rc5:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:rc6:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:rc4:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0.4:rc1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.4.23:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.4.23.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:beta6:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:beta7:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.1:beta3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:beta7.1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.0:beta5:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:digium:asterisk:1.6.1:beta1:*:*:*:*:*:*
  Yes
- -