Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2009-0922

CVE information

Published

13 years ago

Last Modified

4 years ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

PostgreSQL before 8.3.7, 8.2.13, 8.1.17, 8.0.21, and 7.4.25 allows remote authenticated users to cause a denial of service (stack consumption and crash) by triggering a failure in the conversion of a localized error message to a client-specified encoding, as demonstrated using mismatched encoding conversion requests..

CVSSv2.0 Score

Severity
Medium
Base Score
4/10
Exploit Score
8/10
Access Vector
Network
Access Complexity
Low
Authentication Required
Single
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
Partial
Integrity Impact
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:postgresql:postgresql:8.3.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:postgresql:postgresql:7.4.24:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:postgresql:postgresql:8.2.12:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:postgresql:postgresql:8.0.20:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:postgresql:postgresql:8.1.16:*:*:*:*:*:*:*
  Yes
- -