CVE-2009-3616 Details

CVE-2009-3616

Published: 2009-10-23
Last Modified: 2009-12-19
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

Multiple use-after-free vulnerabilities in vnc.c in the VNC server in QEMU 0.10.6 and earlier might allow guest OS users to execute arbitrary code on the host OS by establishing a connection from a VNC client and then (1) disconnecting during data transfer, (2) sending a message using incorrect integer data types, or (3) using the Fuzzy Screen Mode protocol, related to double free vulnerabilities.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 8.5/10
Exploit Score 6.8/10
Access Vector Network
Access Complexity Medium
Authentication Single
Impact Score 10/10
Confidentiality Impact Complete
Availability Impact Complete
Integrity Impact Complete
Vector String AV:N/AC:M/Au:S/C:C/I:C/A:C
Common Vulnerability Score System v3.1

NIST has not assigned a CVSSv3.1 Score.

Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:qemu:qemu:0.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.1.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.1.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.1.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.1.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.1.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.1.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.4.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.4.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.4.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.5.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.5.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.5.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.5.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.5.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.5.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.6.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.6.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.7.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.7.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.7.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.8.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.8.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.8.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.9.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.9.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.10.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.10.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.10.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.10.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.10.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:0.10.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* Yes - -
References

http://git.savannah.gnu.org/cgit/qemu.git/commit/?id=198a0039c5
http://git.savannah.gnu.org/cgit/qemu.git/commit/?id=753b405331
http://marc.info/?l=qemu-devel&m=124324043812915
http://rhn.redhat.com/errata/RHEA-2009-1272.html
http://www.openwall.com/lists/oss-security/2009/10/16/5
http://www.openwall.com/lists/oss-security/2009/10/16/8
http://www.securityfocus.com/bid/36716
https://bugzilla.redhat.com/show_bug.cgi?id=501131
https://bugzilla.redhat.com/show_bug.cgi?id=505641
https://bugzilla.redhat.com/show_bug.cgi?id=508567

CVE ID
CVE-2009-3616
Published
2009-10-23
Modified
2009-12-19
CVSSv2.0
High
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-399

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.