CVE-2010-0161

CVE information

Published

12 years ago

Last Modified

4 years ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

The nsAuthSSPI::Unwrap function in extensions/auth/nsAuthSSPI.cpp in Mozilla Thunderbird before 2.0.0.24 and SeaMonkey before 1.1.19 on Windows Vista, Windows Server 2008 R2, and Windows 7 allows remote SMTP, IMAP, and POP servers to cause a denial of service (heap memory corruption and application crash) or possibly execute arbitrary code via crafted data in a session that uses SSPI..

CVSSv2.0 Score

Severity
Medium
Base Score
4.3/10
Exploit Score
8.6/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
None
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
Partial
Integrity Impact
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:mozilla:thunderbird:1.5.0.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.7.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.21:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.0.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.16:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.18:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.13:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.10:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.22:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.12:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.17:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.14:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.14:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.11:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.0.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.7.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:2.0.0.19:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.0.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.7.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.12:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.5.0.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:1.0.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:mozilla:thunderbird:0.4:*:*:*:*:*:*:*
  Yes
- -

Get started for free to scan for vulnerabilities

Companies of all sizes use Mageni to scan their assets for vulnerabilities. Mageni is free for 7-days then $39 USD Monthly regardless of how many IPs, scans, deployments or users you have. Cancel at Anytime and 7-days Money-Back Guarantee. Developed and supported by certified CompTIA PenTest+ professionals. Mageni contributes 1% of your subscription to removing CO₂ from the atmosphere.

Get Started For Free
App screenshot