CVE-2010-0295

CVE information

Published

12 years ago

Last Modified

4 years ago

CVSSv2.0 Severity

Medium

Impact Analysis

Description

lighttpd before 1.4.26, and 1.5.x, allocates a buffer for each read operation that occurs for a request, which allows remote attackers to cause a denial of service (memory consumption) by breaking a request into small pieces that are sent at a slow rate..

CVSSv2.0 Score

Severity
Medium
Base Score
5/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
Partial
Integrity Impact
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:lighttpd:lighttpd:1.4.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.2.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.21:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.2.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.18:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.12:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.15:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.2.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.19:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.13:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.1.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.1.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.2.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.24:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.17:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.14:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.2.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.0.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.11:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.2.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.1.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.5:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.6:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.14:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.13:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.20:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.10:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.16:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.2.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.1.9:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.1.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.23:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.16:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.15:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.2.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.1.8:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.1.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.1.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.5.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.7:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.12:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.11:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.3.10:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.1.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:lighttpd:lighttpd:1.4.22:*:*:*:*:*:*:*
  Yes
- -

Get started for free to scan for vulnerabilities

Companies of all sizes use Mageni to scan their assets for vulnerabilities. Mageni is free for 7-days then $39 USD Monthly regardless of how many IPs, scans, deployments or users you have. Cancel at Anytime and 7-days Money-Back Guarantee. Developed and supported by certified CompTIA PenTest+ professionals. Mageni contributes 1% of your subscription to removing CO₂ from the atmosphere.

Get Started For Free
App screenshot