CVE-2010-1446 Details

CVE-2010-1446

Published: 2010-05-21
Last Modified: 2017-08-17
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

arch/powerpc/mm/fsl_booke_mmu.c in KGDB in the Linux kernel 2.6.30 and other versions before 2.6.33, when running on PowerPC, does not properly perform a security check for access to a kernel page, which allows local users to overwrite arbitrary kernel memory, related to Fsl booke.

Analysis
Common Vulnerability Score System v2.0
Severity Low
Base Score 1.9/10
Exploit Score 3.4/10
Access Vector Local
Access Complexity Medium
Authentication None
Impact Score 2.9/10
Confidentiality Impact None
Availability Impact None
Integrity Impact Partial
Vector String AV:L/AC:M/Au:N/C:N/I:P/A:N
Common Vulnerability Score System v3.1

NIST has not assigned a CVSSv3.1 Score.

Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:o:linux:linux_kernel:2.6.30:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.30.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.30.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.30.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.30.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.30.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.30.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.30.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.30.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.30.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.30.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.11:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.12:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.31.13:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.11:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.12:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:2.6.32.13:*:*:*:*:*:*:* Yes - -
References

http://lists.opensuse.org/opensuse-security-announce/2010-07/msg00006.html
http://lkml.org/lkml/2010/5/10/458
http://secunia.com/advisories/39830
http://secunia.com/advisories/40645
http://www.debian.org/security/2010/dsa-2053
http://www.openwall.com/lists/oss-security/2010/04/29/3
http://www.openwall.com/lists/oss-security/2010/04/29/9
http://www.openwall.com/lists/oss-security/2010/04/30/1
http://www.vupen.com/english/advisories/2010/1857
https://exchange.xforce.ibmcloud.com/vulnerabilities/58840

CVE ID
CVE-2010-1446
Published
2010-05-21
Modified
2017-08-17
CVSSv2.0
Low
PCI Compliance
Pass
US-CERT Alert
No
CWE
CWE-264

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.