Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2011-0332

CVE information

Published

11 years ago

Last Modified

5 years ago

CVSSv2.0 Severity

High

Impact Analysis

Description

Integer overflow in Foxit Reader before 4.3.1.0218 and Foxit Phantom before 2.3.3.1112 allows remote attackers to execute arbitrary code via crafted ICC chunks in a PDF file, which triggers a heap-based buffer overflow..

CVSSv2.0 Score

Severity
High
Base Score
9.3/10
Exploit Score
8.6/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
None
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:foxitsoftware:foxit_reader:4.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:3.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:2.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:2.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:3.3.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:3.1.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:3.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:2.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:3.1.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:3.2.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:3.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:3.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_reader:4.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_phantom:2.2.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_phantom:*:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_phantom:1.0.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_phantom:2.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_phantom:2.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_phantom:2.2.4:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_phantom:2.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_phantom:2.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:foxitsoftware:foxit_phantom:2.2.1:*:*:*:*:*:*:*
  Yes
- -