Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2012-0801

CVE information

Published

10 years ago

Last Modified

2 years ago

CVSSv2.0 Severity

High

Impact Analysis

Description

lib/formslib.php in Moodle 2.1.x before 2.1.4 and 2.2.x before 2.2.1 does not properly handle multiple instances of a form element, which has unspecified impact and remote attack vectors..

CVSSv2.0 Score

Severity
High
Base Score
7.5/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
6.4/10
Confidentiality Impact
Partial
Availability Impact
Partial
Integrity Impact
Partial

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:moodle:moodle:2.1.2:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:moodle:moodle:2.1.1:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:moodle:moodle:2.1.3:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:moodle:moodle:2.1.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:moodle:moodle:2.2.0:*:*:*:*:*:*:*
  Yes
- -