CVE-2012-5689 Details

CVE-2012-5689

Published: 2013-01-25
Last Modified: 2016-08-19
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

ISC BIND 9.8.x through 9.8.4-P1 and 9.9.x through 9.9.2-P1, in certain configurations involving DNS64 with a Response Policy Zone that lacks an AAAA rewrite rule, allows remote attackers to cause a denial of service (assertion failure and named daemon exit) via a query for an AAAA record.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 7.1/10
Exploit Score 8.6/10
Access Vector Network
Access Complexity Medium
Authentication None
Impact Score 6.9/10
Confidentiality Impact None
Availability Impact Complete
Integrity Impact None
Vector String AV:N/AC:M/Au:N/C:N/I:N/A:C
Common Vulnerability Score System v3.1

NIST has not assigned a CVSSv3.1 Score.

Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:isc:bind:9.9.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.0:a1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.0:a2:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.0:a3:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.0:b1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.0:b2:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.0:rc1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.0:rc2:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.0:rc3:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.0:rc4:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.1:p1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.1:p2:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.9.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:redhat:enterprise_linux_hpc_node:6.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:redhat:enterprise_linux_server_aus:6.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:redhat:enterprise_linux_server_eus:6.4.z:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.0:a1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.0:b1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.0:p1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.0:p2:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.0:p4:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.0:rc1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.1:b1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.1:b2:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.1:b3:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.1:p1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.1:rc1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.2:b1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.2:rc1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.2:rc2:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.3:p1:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.3:p2:*:*:*:*:*:* Yes - -
cpe:2.3:a:isc:bind:9.8.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:* Yes - -
cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Yes - -
cpe:2.3:o:canonical:ubuntu_linux:15.04:*:*:*:*:*:*:* Yes - -
References

http://rhn.redhat.com/errata/RHSA-2013-0550.html
http://www.isc.org/software/bind/advisories/cve-2012-5689
http://www.ubuntu.com/usn/USN-2693-1
https://kb.isc.org/article/AA-00855/

CVE ID
CVE-2012-5689
Published
2013-01-25
Modified
2016-08-19
CVSSv2.0
High
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-20

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.