CVE-2014-0109 Details

CVE-2014-0109

Published: 2014-05-08
Last Modified: 2020-11-12
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

Apache CXF before 2.6.14 and 2.7.x before 2.7.11 allows remote attackers to cause a denial of service (memory consumption) via a large request with the Content-Type set to text/html to a SOAP endpoint, which triggers an error.

Analysis
Common Vulnerability Score System v2.0
Severity Medium
Base Score 4.3/10
Exploit Score 8.6/10
Access Vector Network
Access Complexity Medium
Authentication None
Impact Score 2.9/10
Confidentiality Impact None
Availability Impact Partial
Integrity Impact None
Vector String AV:N/AC:M/Au:N/C:N/I:N/A:P
Common Vulnerability Score System v3.1

NIST has not assigned a CVSSv3.1 Score.

Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:apache:cxf:2.7.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.7.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.7.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.7.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.7.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.7.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.7.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.7.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.7.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.7.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.7.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.4.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.4.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.4.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.4.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.4.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.4.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.4.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.4.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.5.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.5.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.5.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.5.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.5.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.5.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.5.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.5.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.5.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.5.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.11:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:2.6.12:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:apache:cxf:*:*:*:*:*:*:*:* Yes - -
References

http://rhn.redhat.com/errata/RHSA-2014-1351.html
http://rhn.redhat.com/errata/RHSA-2015-0850.html
http://rhn.redhat.com/errata/RHSA-2015-0851.html
http://www.securitytracker.com/id/1030201
https://cxf.apache.org/security-advisories.data/CVE-2014-0109.txt.asc?version=1&modifica
https://lists.apache.org/thread.html/r36e44ffc1a9b365327df62cdfaabe85b9a5637de102cea07d7
https://lists.apache.org/thread.html/rc774278135816e7afc943dc9fc78eb0764f2c84a2b96470a01
https://lists.apache.org/thread.html/rd49aabd984ed540c8ff7916d4d79405f3fa311d2fdbcf9ed30
https://lists.apache.org/thread.html/rff42cfa5e7d75b7c1af0e37589140a8f1999e578a75738740b

CVE ID
CVE-2014-0109
Published
2014-05-08
Modified
2020-11-12
CVSSv2.0
Medium
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-399

Free Vulnerability Scanning, Assessment and Management

Mageni's Platform is packed with all the features you need to scan, assess and manage vulnerabilities like this - it is free, open source, lightning fast, reliable and scalable.

Router
Servers
Laptop
Database
Group
Cloud

Frequently Asked Questions

No, you can scan concurrently as many assets as you want. Please note that you must be aware of the hardware requeriments of the platform to ensure a good performance.

No, you can add as many assest as you want. It doesn't matters if you have millions of assets, we won't charge you for that.

No. The software is completely free. We have no intention to charge you to use the software, in fact - it completely goes against our beliefs and business model.

A vulnerability is defined in the ISO 27002 standard as “A weakness of an asset or group of assets that can be exploited by one or more threats” (International Organization for Standardization, 2005)

We generate revenue by providing support and other services for customers that require a subscription so they get guaranteed support and enterprise services. To use Mageni's Platform is completely free, with no limits at all.

Yes. Mageni understands that there are professionals and businesses that need commercial support so Mageni provides an active support subscription with everything needed to run Mageni's Platform reliably and securely. More than software, it's access to security experts, knowledge resources, security updates, and support tools you can't get anywhere else. The subscription includes:

  • Ongoing delivery
    • Patches
    • Bug fixes
    • Updates
    • Upgrades
  • Technical support
    • 24/7 availability
    • Unlimited Incidents
    • Specialty-based routing
    • Multi-Channel
  • Commitments
    • Software certifications
    • Software assurance
    • SLA

No, we don't store the information of your vulnerabilities in our servers.

Vulnerability management is the process in which vulnerabilities in IT are identified and the risks of these vulnerabilities are evaluated. This evaluation leads to correcting the vulnerabilities and removing the risk or a formal risk acceptance by the management of an organization. The term vulnerability management is often confused with vulnerability scanning. Despite the fact both are related, there is an important difference between the two. Vulnerability scanning consists of using a computer program to identify vulnerabilities in networks, computer infrastructure or applications. Vulnerability management is the process surrounding vulnerability scanning, also taking into account other aspects such as risk acceptance, remediation etc. Source: "Implementing a Vulnerability Management Process". SANS Institute.

I am ready to start scanning for vulnerabilities