CVE-2014-3094 Details

CVE-2014-3094

Published: 2014-09-04
Last Modified: 2017-08-29
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

Stack-based buffer overflow in IBM DB2 9.7 through FP9a, 9.8 through FP5, 10.1 through FP4, and 10.5 before FP4 on Linux, UNIX, and Windows allows remote authenticated users to execute arbitrary code via a crafted ALTER MODULE statement.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 8.5/10
Exploit Score 6.8/10
Access Vector Network
Access Complexity Medium
Authentication Single
Impact Score 10/10
Confidentiality Impact Complete
Availability Impact Complete
Integrity Impact Complete
Vector String AV:N/AC:M/Au:S/C:C/I:C/A:C
Common Vulnerability Score System v3.1

NIST has not assigned a CVSSv3.1 Score.

Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:ibm:db2:9.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.7.0.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.7.0.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.7.0.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.7.0.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.7.0.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.7.0.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.7.0.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.7.0.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.7.0.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.7.0.9:a:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.8.0.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.8.0.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:9.8.0.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:10.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:10.1.0.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:10.1.0.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:10.1.0.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:10.1.0.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:10.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:10.5.0.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:10.5.0.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:10.5.0.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:ibm:db2:10.5.0.3:a:*:*:*:*:*:* Yes - -
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* No - -
cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:* No - -
References

http://secunia.com/advisories/58616
http://secunia.com/advisories/60845
http://www.securityfocus.com/bid/69550
http://www-01.ibm.com/support/docview.wss?uid=swg1IT02291
http://www-01.ibm.com/support/docview.wss?uid=swg1IT02592
http://www-01.ibm.com/support/docview.wss?uid=swg1IT02593
http://www-01.ibm.com/support/docview.wss?uid=swg1IT02594
http://www-01.ibm.com/support/docview.wss?uid=swg21681631
http://www-01.ibm.com/support/docview.wss?uid=swg21683296
https://exchange.xforce.ibmcloud.com/vulnerabilities/94260

CVE ID
CVE-2014-3094
Published
2014-09-04
Modified
2017-08-29
CVSSv2.0
High
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-119

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.