CVE-2014-8143 Details

CVE-2014-8143

Published: 2015-01-17
Last Modified: 2017-09-08
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

Samba 4.0.x before 4.0.24, 4.1.x before 4.1.16, and 4.2.x before 4.2rc4, when an Active Directory Domain Controller (AD DC) is configured, allows remote authenticated users to set the LDB userAccountControl UF_SERVER_TRUST_ACCOUNT bit, and consequently gain privileges, by leveraging delegation of authority for user-account or computer-account creation.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 8.5/10
Exploit Score 6.8/10
Access Vector Network
Access Complexity Medium
Authentication Single
Impact Score 10/10
Confidentiality Impact Complete
Availability Impact Complete
Integrity Impact Complete
Vector String AV:N/AC:M/Au:S/C:C/I:C/A:C
Common Vulnerability Score System v3.1

NIST has not assigned a CVSSv3.1 Score.

Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:samba:samba:4.0.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.11:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.12:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.13:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.14:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.15:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.16:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.17:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.18:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.19:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.20:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.21:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.22:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.0.23:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.4:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.5:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.6:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.7:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.8:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.9:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.11:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.12:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.13:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.14:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.1.15:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.2.0:rc1:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.2.0:rc2:*:*:*:*:*:* Yes - -
cpe:2.3:a:samba:samba:4.2.0:rc3:*:*:*:*:*:* Yes - -
References

http://lists.opensuse.org/opensuse-security-announce/2015-02/msg00031.html
http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00042.html
http://secunia.com/advisories/62594
http://www.securityfocus.com/bid/72278
http://www.securitytracker.com/id/1031615
http://www.slackware.com/security/viewer.php?l=slackware-security&y=2015&m=slackware-security.416326
http://www.ubuntu.com/usn/USN-2481-1
https://download.samba.org/pub/samba/patches/security/samba-4.0.23-CVE-2014-8143.patch
https://download.samba.org/pub/samba/patches/security/samba-4.1.15-CVE-2014-8143.patch
https://exchange.xforce.ibmcloud.com/vulnerabilities/100596
https://www.samba.org/samba/security/CVE-2014-8143

CVE ID
CVE-2014-8143
Published
2015-01-17
Modified
2017-09-08
CVSSv2.0
High
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-264

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.