CVE-2015-5343 Details

CVE-2015-5343

Published: 2016-04-14
Last Modified: 2019-02-12
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

Integer overflow in util.c in mod_dav_svn in Apache Subversion 1.7.x, 1.8.x before 1.8.15, and 1.9.x before 1.9.3 allows remote authenticated users to cause a denial of service (subversion server crash or memory consumption) and possibly execute arbitrary code via a skel-encoded request body, which triggers an out-of-bounds read and heap-based buffer overflow.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 8/10
Exploit Score 8/10
Access Vector Network
Access Complexity Low
Authentication Single
Impact Score 8.5/10
Confidentiality Impact Partial
Availability Impact Complete
Integrity Impact Partial
Vector String AV:N/AC:L/Au:S/C:P/I:P/A:C
Common Vulnerability Score System v3.1
Severity High
Base Score 7.6/10
Exploit Score 2.8/10
Access Vector Network
Access Complexity Low
Privileges Required Low
Impact Score 4.7/10
Confidentiality Impact Low
Availability Impact High
Integrity Impact Low
Scope Unchanged
User Interaction None
Vector String CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H
Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:apache:subversion:*:*:*:*:*:*:*:* Yes 1.7.0 -
cpe:2.3:a:apache:subversion:*:*:*:*:*:*:*:* Yes 1.8.0 1.8.15
cpe:2.3:a:apache:subversion:*:*:*:*:*:*:*:* Yes 1.9.0 1.9.3
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Yes - -
References

http://subversion.apache.org/security/CVE-2015-5343-advisory.txt
http://www.debian.org/security/2015/dsa-3424
http://www.securitytracker.com/id/1034470
http://www.slackware.com/security/viewer.php?l=slackware-security&y=2016&m=slackware-security.405261

CVE ID
CVE-2015-5343
Published
2016-04-14
Modified
2019-02-12
CVSSv2.0
High
CVSSv3.1
High
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-119

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.