CVE-2016-9814 Details

CVE-2016-9814

Published: 2017-02-17
Last Modified: 2018-03-04
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 8.5/10
Exploit Score 10/10
Access Vector Network
Access Complexity Low
Authentication None
Impact Score 7.8/10
Confidentiality Impact None
Availability Impact Complete
Integrity Impact Partial
Vector String AV:N/AC:L/Au:N/C:N/I:P/A:C
Common Vulnerability Score System v3.1
Severity Critical
Base Score 9.1/10
Exploit Score 3.9/10
Access Vector Network
Access Complexity Low
Privileges Required None
Impact Score 5.2/10
Confidentiality Impact None
Availability Impact High
Integrity Impact High
Scope Unchanged
User Interaction None
Vector String CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:simplesamlphp:simplesamlphp:1.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:saml2:*:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:saml2:1.10:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:saml2:1.10.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:saml2:1.10.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:saml2:2.0.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:saml2:2.0.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:saml2:2.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:saml2:2.2:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:saml2:2.3:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:saml2:2.3.1:*:*:*:*:*:*:* Yes - -
cpe:2.3:a:simplesamlphp:saml2:2.3.2:*:*:*:*:*:*:* Yes - -
References

http://www.securityfocus.com/bid/94730
https://lists.debian.org/debian-lts-announce/2018/03/msg00001.html
https://simplesamlphp.org/security/201612-01

CVE ID
CVE-2016-9814
Published
2017-02-17
Modified
2018-03-04
CVSSv2.0
High
CVSSv3.1
Critical
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-399

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.