CVE-2017-14444 Details

CVE-2017-14444

Published: 2018-08-02
Last Modified: 2018-09-27
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

An exploitable buffer overflow vulnerability exists in Insteon Hub running firmware version 1012. The HTTP server implementation incorrectly handles the URL parameter during a firmware update request, leading to a buffer overflow on a global section. An attacker can send an HTTP GET request to trigger this vulnerability.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 8/10
Exploit Score 8/10
Access Vector Network
Access Complexity Low
Authentication Single
Impact Score 8.5/10
Confidentiality Impact Partial
Availability Impact Complete
Integrity Impact Partial
Vector String AV:N/AC:L/Au:S/C:P/I:P/A:C
Common Vulnerability Score System v3.1
Severity Critical
Base Score 9.9/10
Exploit Score 3.1/10
Access Vector Network
Access Complexity Low
Privileges Required Low
Impact Score 6/10
Confidentiality Impact High
Availability Impact High
Integrity Impact High
Scope Changed
User Interaction None
Vector String CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:o:insteon:hub_firmware:1012:*:*:*:*:*:*:* Yes - -
cpe:2.3:h:insteon:hub:-:*:*:*:*:*:*:* No - -
References

https://www.talosintelligence.com/vulnerability_reports/TALOS-2017-0493

CVE ID
CVE-2017-14444
Published
2018-08-02
Modified
2018-09-27
CVSSv2.0
High
CVSSv3.1
Critical
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-119

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.