CVE-2017-16929 Details

CVE-2017-16929

Published: 2017-12-05
Last Modified: 2017-12-21
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

The remote management interface on the Claymore Dual GPU miner 10.1 is vulnerable to an authenticated directory traversal vulnerability exploited by issuing a specially crafted request, allowing a remote attacker to read/write arbitrary files. This can be exploited via ../ sequences in the pathname to miner_file or miner_getfile.

Analysis
Common Vulnerability Score System v2.0
Metrics Value
Severity High
Base Score 8.5/10
Exploit Score 8/10
Access Vector Network
Access Complexity Low
Authentication Single
Impact Score 9.2/10
Confidentiality Impact Complete
Availability Impact None
Integrity Impact Complete
Vector String AV:N/AC:L/Au:S/C:C/I:C/A:N
Common Vulnerability Score System v3.1
Metrics Value
Severity High
Base Score 8.1/10
Exploit Score 2.8/10
Access Vector Network
Access Complexity Low
Privileges Required Low
Impact Score 5.2/10
Confidentiality Impact High
Availability Impact None
Integrity Impact High
Scope Unchanged
User Interaction None
Vector String CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:claymore_dual_miner_project:claymore_dual_miner:10.1:*:*:*:*:*:*:* Yes - -
References

http://www.openwall.com/lists/oss-security/2017/12/04/3
https://github.com/tintinweb/pub/tree/master/pocs/cve-2017-16929
https://www.exploit-db.com/exploits/43231/

CVE ID
CVE-2017-16929
Published
2017-12-05
Modified
2017-12-21
CVSSv2.0
High
CVSSv3.1
High
PCI Compliance
Fail
Data Format
MITRE
Data Type
CVE
Data Version
4.0
CWE

CWE-22

CWE-119

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.