Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2018-0092

CVE information

Published

4 years ago

Last Modified

3 years ago

CVSSv2.0 Severity

Low

CVSSv3.1 Severity

High

Impact Analysis

Description

A vulnerability in the network-operator user role implementation for Cisco NX-OS System Software could allow an authenticated, local attacker to improperly delete valid user accounts. The network-operator role should not be able to delete other configured users on the device. The vulnerability is due to a lack of proper role-based access control (RBAC) checks for the actions that a user with the network-operator role is allowed to perform. An attacker could exploit this vulnerability by authenticating to the device with user credentials that give that user the network-operator role. Successful exploitation could allow the attacker to impact the integrity of the device by deleting configured user credentials. The attacker would need valid user credentials for the device. This vulnerability affects the following Cisco products running Cisco NX-OS System Software: Nexus 3000 Series Switches, Nexus 3600 Platform Switches, Nexus 9000 Series Switches in standalone NX-OS mode, Nexus 9500 R-Series Line Cards and Fabric Modules. Cisco Bug IDs: CSCvg21120..

CVSSv2.0 Score

Severity
Low
Base Score
3.6/10
Exploit Score
3.9/10
Access Vector
Local
Access Complexity
Low
Authentication Required
None
Impact Score
4.9/10
Confidentiality Impact
None
Availability Impact
Partial
Integrity Impact
Partial

CVSSv3.1 Score

Severity
High
Base Score
7.1/10
Exploit Score
1.8/10
Access Vector
Local
Access Complexity
Low
Privileges Required
Low
Impact Score
5.2/10
Confidentiality Impact
None
Availability Impact
High
Integrity Impact
High
Scope
Unchanged
User Interaction
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:o:cisco:nx-os:7.0\(3\)i7\(1\):*:*:*:*:*:*:*
  Yes
-
cpe:2.3:o:cisco:nx-os:7.0\(3\)i5\(2\):*:*:*:*:*:*:*
  Yes
-
cpe:2.3:o:cisco:nx-os:7.0\(3\)i6\(1\):*:*:*:*:*:*:*
  Yes
-
cpe:2.3:h:cisco:nexus_93128tx_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_9372tx-e_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_9236c_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_9372px_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_9396tx_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_93180lc-ex_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_92300yc_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_9272q_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_93120tx_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_93108tc-ex_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_92160yc_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_9372tx_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_9396px_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_92304qc_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_93180yc-ex_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_9336pq_aci_spine_switch:-:*:*:*:*:*:*:
  No
-
cpe:2.3:h:cisco:nexus_9508_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_9332pq_switch:-:*:*:*:*:*:*:*
  No
-
cpe:2.3:h:cisco:nexus_9372px-e_switch:-:*:*:*:*:*:*:*
  No
-