Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2018-0221

CVE information

Published

4 years ago

Last Modified

3 years ago

CVSSv2.0 Severity

High

CVSSv3.1 Severity

Medium

Impact Analysis

Description

A vulnerability in specific CLI commands for the Cisco Identity Services Engine (ISE) could allow an authenticated, local attacker to perform command injection to the underlying operating system or cause a hang or disconnect of the user session. The attacker needs valid administrator credentials for the device. The vulnerability is due to incomplete input validation of user input for certain CLI ISE configuration commands. An attacker could exploit this vulnerability by authenticating as an administrative user, issuing a specific CLI command, and entering crafted, malicious user input for the command parameters. An exploit could allow the attacker to perform command injection to the lower-level Linux operating system. It is also possible the attacker could cause the ISE user interface for this management session to hang or disconnect. Cisco Bug IDs: CSCvg95479..

CVSSv2.0 Score

Severity
High
Base Score
7.2/10
Exploit Score
3.9/10
Access Vector
Local
Access Complexity
Low
Authentication Required
None
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

CVSSv3.1 Score

Severity
Medium
Base Score
6.7/10
Exploit Score
0.8/10
Access Vector
Local
Access Complexity
Low
Privileges Required
High
Impact Score
5.9/10
Confidentiality Impact
High
Availability Impact
High
Integrity Impact
High
Scope
Unchanged
User Interaction
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:cisco:identity_services_engine:2.1\(0.474\):*:*:*:
  Yes
- -
cpe:2.3:a:cisco:identity_services_engine:2.0\(0.249\):*:*:*:
  Yes
- -
cpe:2.3:a:cisco:identity_services_engine:2.3\(0.298\):*:*:*:
  Yes
- -
cpe:2.3:a:cisco:identity_services_engine:2.2\(0.470\):*:*:*:
  Yes
- -
cpe:2.3:a:cisco:identity_services_engine:2.2\(0.903\):*:*:*:
  Yes
- -
cpe:2.3:a:cisco:identity_services_engine:2.4\(0.192\):*:*:*:
  Yes
- -