Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2018-0227

CVE information

Published

4 years ago

Last Modified

5 months ago

CVSSv2.0 Severity

Medium

CVSSv3.1 Severity

High

Impact Analysis

Description

A vulnerability in the Secure Sockets Layer (SSL) Virtual Private Network (VPN) Client Certificate Authentication feature for Cisco Adaptive Security Appliance (ASA) could allow an unauthenticated, remote attacker to establish an SSL VPN connection and bypass certain SSL certificate verification steps. The vulnerability is due to incorrect verification of the SSL Client Certificate. An attacker could exploit this vulnerability by connecting to the ASA VPN without a proper private key and certificate pair. A successful exploit could allow the attacker to establish an SSL VPN connection to the ASA when the connection should have been rejected. This vulnerability affects Cisco Adaptive Security Appliance (ASA) and Firepower Threat Defense (FTD) Software that is running on the following Cisco products: 3000 Series Industrial Security Appliances (ISA), ASA 5500 Series Adaptive Security Appliances, ASA 5500-X Series Next-Generation Firewalls, ASA Services Module for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers, Adaptive Security Virtual Appliances (ASAv), Firepower 4110 Security Appliances, Firepower 9300 ASA Security Modules. Cisco Bug IDs: CSCvg40155..

CVSSv2.0 Score

Severity
Medium
Base Score
5/10
Exploit Score
10/10
Access Vector
Network
Access Complexity
Low
Authentication Required
None
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
None
Integrity Impact
Partial

CVSSv3.1 Score

Severity
High
Base Score
7.5/10
Exploit Score
3.9/10
Access Vector
Network
Access Complexity
Low
Privileges Required
None
Impact Score
3.6/10
Confidentiality Impact
None
Availability Impact
None
Integrity Impact
High
Scope
Unchanged
User Interaction
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*
  Yes
9.6.2.9 -
cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*
  Yes
9.6.3 -
cpe:2.3:o:cisco:adaptive_security_appliance_software:9.5.2.7
  Yes
- -
cpe:2.3:o:cisco:adaptive_security_appliance_software:9.5.2.8
  Yes
- -
cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*
  Yes
9.5.3.7 -
cpe:2.3:o:cisco:adaptive_security_appliance_software:9.4.3.1
  Yes
- -
cpe:2.3:o:cisco:adaptive_security_appliance_software:9.4.3.2
  Yes
- -
cpe:2.3:o:cisco:adaptive_security_appliance_software:*:*:*:*
  Yes
9.4.4 -
cpe:2.3:a:cisco:firepower_threat_defense:*:*:*:*:*:*:*:*
  Yes
6.0 -
cpe:2.3:a:cisco:firepower_threat_defense:*:*:*:*:*:*:*:*
  Yes
6.1.0 -