CVE-2018-14654 Details

CVE-2018-14654

Published: 2018-10-31
Last Modified: 2019-04-02
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

The Gluster file system through version 4.1.4 is vulnerable to abuse of the 'features/index' translator. A remote attacker with access to mount volumes could exploit this via the 'GF_XATTROP_ENTRY_IN_KEY' xattrop to create arbitrary, empty files on the target server.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 8.5/10
Exploit Score 8/10
Access Vector Network
Access Complexity Low
Authentication Single
Impact Score 9.2/10
Confidentiality Impact None
Availability Impact Complete
Integrity Impact Complete
Vector String AV:N/AC:L/Au:S/C:N/I:C/A:C
Common Vulnerability Score System v3.1
Severity Medium
Base Score 6.5/10
Exploit Score 2.8/10
Access Vector Network
Access Complexity Low
Privileges Required Low
Impact Score 3.6/10
Confidentiality Impact None
Availability Impact None
Integrity Impact High
Scope Unchanged
User Interaction None
Vector String CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:redhat:gluster_storage:*:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* Yes - -
cpe:2.3:o:redhat:enterprise_linux_virtualization:4.0:*:*:*:*:*:*:* Yes - -
References

https://access.redhat.com/errata/RHSA-2018:3431
https://access.redhat.com/errata/RHSA-2018:3432
https://access.redhat.com/errata/RHSA-2018:3470
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-14654
https://security.gentoo.org/glsa/201904-06

CVE ID
CVE-2018-14654
Published
2018-10-31
Modified
2019-04-02
CVSSv2.0
High
CVSSv3.1
Medium
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-20

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.