Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2019-0204

CVE information

Published

3 years ago

Last Modified

1 year ago

CVSSv2.0 Severity

High

CVSSv3.1 Severity

High

Impact Analysis

Description

A specifically crafted Docker image running under the root user can overwrite the init helper binary of the container runtime and/or the command executor in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.2, 1.6.0 to 1.6.1, and 1.7.0 to 1.7.1. A malicious actor can therefore gain root-level code execution on the host..

CVSSv2.0 Score

Severity
High
Base Score
9.3/10
Exploit Score
8.6/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
None
Impact Score
10/10
Confidentiality Impact
Complete
Availability Impact
Complete
Integrity Impact
Complete

CVSSv3.1 Score

Severity
High
Base Score
7.8/10
Exploit Score
1.8/10
Access Vector
Local
Access Complexity
Low
Privileges Required
None
Impact Score
5.9/10
Confidentiality Impact
High
Availability Impact
High
Integrity Impact
High
Scope
Unchanged
User Interaction
Required

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:apache:mesos:*:*:*:*:*:*:*:*
  Yes
1.4.0 1.4.3
cpe:2.3:a:apache:mesos:*:*:*:*:*:*:*:*
  Yes
1.6.0 1.6.2
cpe:2.3:a:apache:mesos:1.8.0:dev:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:apache:mesos:*:*:*:*:*:*:*:*
  Yes
1.7.0 1.7.2
cpe:2.3:a:apache:mesos:*:*:*:*:*:*:*:*
  Yes
1.5.0 1.5.3
cpe:2.3:a:redhat:fuse:7.5.0:*:*:*:*:*:*:*
  Yes
- -