Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2019-0257

CVE information

Published

3 years ago

Last Modified

1 year ago

CVSSv2.0 Severity

Medium

CVSSv3.1 Severity

High

Impact Analysis

Description

Customizing functionality of SAP NetWeaver AS ABAP Platform (fixed in versions from 7.0 to 7.02, from 7.10 to 7.11, 7.30, 7.31, 7.40, from 7.50 to 7.53, from 7.74 to 7.75) does not perform necessary authorization checks for an authenticated user, resulting in escalation of privileges..

CVSSv2.0 Score

Severity
Medium
Base Score
6.5/10
Exploit Score
8/10
Access Vector
Network
Access Complexity
Low
Authentication Required
Single
Impact Score
6.4/10
Confidentiality Impact
Partial
Availability Impact
Partial
Integrity Impact
Partial

CVSSv3.1 Score

Severity
High
Base Score
8.8/10
Exploit Score
2.8/10
Access Vector
Network
Access Complexity
Low
Privileges Required
Low
Impact Score
5.9/10
Confidentiality Impact
High
Availability Impact
High
Integrity Impact
High
Scope
Unchanged
User Interaction
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:sap:netweaver_abap:7.40:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:sap:netweaver_abap:7.31:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:sap:netweaver_abap:*:*:*:*:*:*:*:*
  Yes
7.74 -
cpe:2.3:a:sap:netweaver_abap:*:*:*:*:*:*:*:*
  Yes
7.50 -
cpe:2.3:a:sap:netweaver_abap:7.30:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:sap:netweaver_abap:*:*:*:*:*:*:*:*
  Yes
7.10 -
cpe:2.3:a:sap:netweaver_abap:*:*:*:*:*:*:*:*
  Yes
7.0 -