Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2019-0271

CVE information

Published

3 years ago

Last Modified

3 months ago

CVSSv2.0 Severity

Medium

CVSSv3.1 Severity

Medium

Impact Analysis

Description

ABAP Server (used in NetWeaver and Suite/ERP) and ABAP Platform does not sufficiently validate an XML document accepted from an untrusted source, leading to an XML External Entity (XEE) vulnerability. Fixed in Kernel 7.21 or 7.22, that is ABAP Server 7.00 to 7.31 and Kernel 7.45, 7.49 or 7.53, that is ABAP Server 7.40 to 7.52 or ABAP Platform. For more recent updates please refer to Security Note 2870067 (which supersedes the solution of Security Note 2736825) in the reference section below..

CVSSv2.0 Score

Severity
Medium
Base Score
4/10
Exploit Score
8/10
Access Vector
Network
Access Complexity
Low
Authentication Required
Single
Impact Score
2.9/10
Confidentiality Impact
None
Availability Impact
Partial
Integrity Impact
None

CVSSv3.1 Score

Severity
Medium
Base Score
6.5/10
Exploit Score
2.8/10
Access Vector
Network
Access Complexity
Low
Privileges Required
Low
Impact Score
3.6/10
Confidentiality Impact
None
Availability Impact
High
Integrity Impact
None
Scope
Unchanged
User Interaction
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:sap:advanced_business_application_programming_plat
  Yes
- -
cpe:2.3:a:sap:advanced_business_application_programming_serv
  Yes
7.00 -
cpe:2.3:a:sap:advanced_business_application_programming_serv
  Yes
7.40 -
cpe:2.3:a:sap:sap_kernel:7.22:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:sap:sap_kernel:7.21:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:sap:sap_kernel:7.45:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:sap:sap_kernel:7.49:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:sap:sap_kernel:7.53:*:*:*:*:*:*:*
  Yes
- -