CVE-2020-13415 Details

CVE-2020-13415

Published: 2020-05-22
Last Modified: 2020-05-26
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

An issue was discovered in Aviatrix Controller through 5.1. An attacker with any signed SAML assertion from the Identity Provider can establish a connection (even if that SAML assertion has expired or is from a user who is not authorized to access Aviatrix), aka XML Signature Wrapping.

Analysis
Common Vulnerability Score System v2.0
Severity Medium
Base Score 5/10
Exploit Score 10/10
Access Vector Network
Access Complexity Low
Authentication None
Impact Score 2.9/10
Confidentiality Impact None
Availability Impact None
Integrity Impact Partial
Vector String AV:N/AC:L/Au:N/C:N/I:P/A:N
Common Vulnerability Score System v3.1
Severity High
Base Score 7.5/10
Exploit Score 3.9/10
Access Vector Network
Access Complexity Low
Privileges Required None
Impact Score 3.6/10
Confidentiality Impact None
Availability Impact None
Integrity Impact High
Scope Unchanged
User Interaction None
Vector String CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:aviatrix:controller:*:*:*:*:*:*:*:* Yes - -
References

https://docs.aviatrix.com/HowTos/security_bulletin_article.html#xml-signature-wrapping-in-saml

CVE ID
CVE-2020-13415
Published
2020-05-22
Modified
2020-05-26
CVSSv2.0
Medium
CVSSv3.1
High
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-347

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.