CVE-2020-13417 Details

CVE-2020-13417

Published: 2020-05-22
Last Modified: 2020-05-26
CVE Author: NIST National Vulnerability Database
CVE Assigner: cve@mitre.org
Summary

An Elevation of Privilege issue was discovered in Aviatrix VPN Client before 2.10.7, because of an incomplete fix for CVE-2020-7224. This affects Linux, macOS, and Windows installations for certain OpenSSL parameters.

Analysis
Common Vulnerability Score System v2.0
Severity High
Base Score 7.5/10
Exploit Score 10/10
Access Vector Network
Access Complexity Low
Authentication None
Impact Score 6.4/10
Confidentiality Impact Partial
Availability Impact Partial
Integrity Impact Partial
Vector String AV:N/AC:L/Au:N/C:P/I:P/A:P
Common Vulnerability Score System v3.1
Severity Critical
Base Score 9.8/10
Exploit Score 3.9/10
Access Vector Network
Access Complexity Low
Privileges Required None
Impact Score 5.9/10
Confidentiality Impact High
Availability Impact High
Integrity Impact High
Scope Unchanged
User Interaction None
Vector String CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Products Reported
CPE Vulnerable Start Excluding
cpe:2.3:a:aviatrix:controller:*:*:*:*:*:*:*:* Yes - 5.3
cpe:2.3:a:aviatrix:gateway:*:*:*:*:*:*:*:* Yes - 5.3
cpe:2.3:a:aviatrix:vpn_client:*:*:*:*:*:*:*:* Yes - 2.10.7
cpe:2.3:o:apple:mac_os:-:*:*:*:*:*:*:* No - -
cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:*:* No - -
cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* No - -
References

https://docs.aviatrix.com/HowTos/security_bulletin_article.html#openvpn-client-elevation-of-privilege

CVE ID
CVE-2020-13417
Published
2020-05-22
Modified
2020-05-26
CVSSv2.0
High
CVSSv3.1
Critical
PCI Compliance
Fail
US-CERT Alert
No
CWE
CWE-269

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities.