Free and open-source vulnerability scanner

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

CVE-2021-4160

CVE information

Published

2 years ago

Last Modified

3 weeks ago

CVSSv2.0 Severity

Medium

CVSSv3.1 Severity

Medium

Impact Analysis

Description

There is a carry propagation bug in the MIPS32 and MIPS64 squaring procedure. Many EC algorithms are affected, including some of the TLS 1.3 default curves. Impact was not analyzed in detail, because the pre-requisites for attack are considered unlikely and include reusing private keys. Analysis suggests that attacks against RSA and DSA as a result of this defect would be very difficult to perform and are not believed likely. Attacks against DH are considered just feasible (although very difficult) because most of the work necessary to deduce information about a private key may be performed offline. The amount of resources required for such an attack would be significant. However, for an attack on TLS to be meaningful, the server would have to share the DH private key among multiple clients, which is no longer an option since CVE-2016-0701. This issue affects OpenSSL versions 1.0.2, 1.1.1 and 3.0.0. It was addressed in the releases of 1.1.1m and 3.0.1 on the 15th of December 2021. For the 1.0.2 release it is addressed in git commit 6fc1aaaf3 that is available to premium support customers only. It will be made available in 1.0.2zc when it is released. The issue only affects OpenSSL on MIPS platforms. Fixed in OpenSSL 3.0.1 (Affected 3.0.0). Fixed in OpenSSL 1.1.1m (Affected 1.1.1-1.1.1l). Fixed in OpenSSL 1.0.2zc-dev (Affected 1.0.2-1.0.2zb)..

CVSSv2.0 Score

Severity
Medium
Base Score
4.3/10
Exploit Score
8.6/10
Access Vector
Network
Access Complexity
Medium
Authentication Required
None
Impact Score
2.9/10
Confidentiality Impact
Partial
Availability Impact
None
Integrity Impact
None

CVSSv3.1 Score

Severity
Medium
Base Score
5.9/10
Exploit Score
2.2/10
Access Vector
Network
Access Complexity
High
Privileges Required
None
Impact Score
3.6/10
Confidentiality Impact
High
Availability Impact
None
Integrity Impact
None
Scope
Unchanged
User Interaction
None

Products Affected

CPE Affected Vulnerable Excluding Edit
cpe:2.3:a:openssl:openssl:3.0.0:-:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha10:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha11:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha12:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha13:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha14:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha15:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha16:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha17:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha3:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha4:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha5:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha6:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha7:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha8:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:alpha9:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:beta1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:3.0.0:beta2:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*
  Yes
1.0.2 -
cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:*
  Yes
1.1.1 1.1.1m
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:jd_edwards_world_security:a9.4:*:*:*:*:*:*:
  Yes
- -
cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.58:*:*:
  Yes
- -
cpe:2.3:a:oracle:peoplesoft_enterprise_peopletools:8.59:*:*:
  Yes
- -
cpe:2.3:a:oracle:jd_edwards_enterpriseone_tools:9.2.6.3:*:*:
  Yes
- -
cpe:2.3:a:oracle:health_sciences_inform_publisher:6.3.1.1:*:
  Yes
- -
cpe:2.3:a:oracle:health_sciences_inform_publisher:6.2.1.1:*:
  Yes
- -
cpe:2.3:a:siemens:sinec_ins:1.0:sp1:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:siemens:sinec_ins:*:*:*:*:*:*:*:*
  Yes
- 1.0
cpe:2.3:a:siemens:sinec_ins:1.0:-:*:*:*:*:*:*
  Yes
- -
cpe:2.3:a:oracle:enterprise_manager_ops_center:12.4.0.0:*:*:
  Yes
- -