Vulnerability Details

Adobe Photoshop CC Multiple Vulnerabilities August19 (Mac OS X.)

Published: 2019-08-14 11:52:04
CVE Author: NIST National Vulnerability Database

CVSS Base Vector:
AV:N/AC:L/Au:N/C:C/I:C/A:C

Summary:
The host is installed with Adobe Photoshop CC and is prone to multiple vulnerabilities.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
Multiple flaws are due to, - Heap overflow errors, - Type confusion errors, - Out of bound read errors, - Command injection errors and - Out of bound write errors.

Impact:
Successful exploitation will allow remote attackers to execute arbitrary code in the context of the application and leak the memory.

Affected Versions:
Adobe Photoshop CC 2018 19.1.8 and earlier and Adobe Photoshop CC 2019 20.0.5 and earlier versions on Mac OS X..

Recommendations:
Upgrade to Adobe Photoshop CC 2018 19.1.9 or Photoshop CC 2019 20.0.6 or later. Please see the references for more information.

Solution Type:
Vendor Patch

Detection Type:
Executable

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2019-7968
https://nvd.nist.gov/vuln/detail/CVE-2019-7969
https://nvd.nist.gov/vuln/detail/CVE-2019-7970
https://nvd.nist.gov/vuln/detail/CVE-2019-7971
https://nvd.nist.gov/vuln/detail/CVE-2019-7972
https://nvd.nist.gov/vuln/detail/CVE-2019-7973
https://nvd.nist.gov/vuln/detail/CVE-2019-7974
https://nvd.nist.gov/vuln/detail/CVE-2019-7975
https://nvd.nist.gov/vuln/detail/CVE-2019-7976
https://nvd.nist.gov/vuln/detail/CVE-2019-7977
https://nvd.nist.gov/vuln/detail/CVE-2019-7978
https://nvd.nist.gov/vuln/detail/CVE-2019-7979
https://nvd.nist.gov/vuln/detail/CVE-2019-7980
https://nvd.nist.gov/vuln/detail/CVE-2019-7981
https://nvd.nist.gov/vuln/detail/CVE-2019-7982
https://nvd.nist.gov/vuln/detail/CVE-2019-7983
https://nvd.nist.gov/vuln/detail/CVE-2019-7984
https://nvd.nist.gov/vuln/detail/CVE-2019-7985
https://nvd.nist.gov/vuln/detail/CVE-2019-7986
https://nvd.nist.gov/vuln/detail/CVE-2019-7987
https://nvd.nist.gov/vuln/detail/CVE-2019-7988
https://nvd.nist.gov/vuln/detail/CVE-2019-7989
https://nvd.nist.gov/vuln/detail/CVE-2019-7990
https://nvd.nist.gov/vuln/detail/CVE-2019-7991
https://nvd.nist.gov/vuln/detail/CVE-2019-7992
https://nvd.nist.gov/vuln/detail/CVE-2019-7993
https://nvd.nist.gov/vuln/detail/CVE-2019-7994
https://nvd.nist.gov/vuln/detail/CVE-2019-7995
https://nvd.nist.gov/vuln/detail/CVE-2019-7996
https://nvd.nist.gov/vuln/detail/CVE-2019-7997
https://nvd.nist.gov/vuln/detail/CVE-2019-7998
https://nvd.nist.gov/vuln/detail/CVE-2019-7999
https://nvd.nist.gov/vuln/detail/CVE-2019-8000
https://nvd.nist.gov/vuln/detail/CVE-2019-8001

References:

https://helpx.adobe.com/security/products/photoshop/apsb19-44.html

Severity
High
CVSS Score
10.0
Published
2019-08-14
Modified
2019-08-14
Category
General

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.