Adobe Reader/Acrobat Denial of Service Vulnerability (May09)

Information

Severity

Severity

Critical

Family

Family

Denial of Service

CVSSv2 Base

CVSSv2 Base

9.3

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:M/Au:N/C:C/I:C/A:C

Solution Type

Solution Type

Vendor Patch

Created

Created

13 years ago

Modified

Modified

3 years ago

Summary

This host is installed with Adobe Reader/Acrobat and is prone to Denial of Service vulnerability.

Insight

Insight

This flaw is due to memory corruption error in 'getAnnots' methods in the JavaScript API while processing malicious PDF files that calls this vulnerable method with crafted integer arguments.

Affected Software

Affected Software

Adobe Reader/Acrobat version 9.1 and prior on Windows.

Detection Method

Detection Method

Checks if a vulnerable version is present on the target host.

Solution

Solution

Upgrade to Adobe Reader/Acrobat version 9.3.2 or later.

Common Vulnerabilities and Exposures (CVE)

Get started for free to scan for vulnerabilities

Companies of all sizes use Mageni to scan their assets for vulnerabilities. Mageni is free for 7-days then $39 USD Monthly regardless of how many IPs, scans, deployments or users you have. Cancel at Anytime and 7-days Money-Back Guarantee. Developed and supported by certified CompTIA PenTest+ professionals. Mageni contributes 1% of your subscription to removing CO₂ from the atmosphere.

Get Started For Free
App screenshot