Amazon Linux Local Check: ALAS-2013-213

Published: 2015-09-08 11:26:20
CVE Author: NIST National Vulnerability Database

Technical Details:
Puppet 2.7.x before 2.7.22 and 3.2.x before 3.2.2, and Puppet Enterprise before 2.8.2, deserializes untrusted YAML, which allows remote attackers to instantiate arbitrary Ruby classes and execute arbitrary code via a crafted REST API call.

Recommendations:
Run yum update puppet to update your system.

Solution Type:
Vendor Patch

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Detection Type:
Linux Distribution Package

Summary:
Amazon Linux Local Security Checks

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2013-3567

CVE Analysis

https://www.mageni.net/cve/CVE-2013-3567

References:

https://alas.aws.amazon.com/ALAS-2013-213.html

Severity
High
CVSS Score
7.5
Published
2015-09-08
Modified
2018-10-01
Category
Amazon Linux Local Security Checks

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.