Zero-friction vulnerability management platform

Mageni eases for you the vulnerability scanning, assessment, and management process. It is free and open-source.

Install Now

Available for macOS, Windows, and Linux

App screenshot

Apache HTTP Server 2.4.49 Directory Traversal / RCE Vulnerability - Active Check

Information

Severity

Severity

Medium

Family

Family

Web Servers

CVSSv2 Base

CVSSv2 Base

5.0

CVSSv2 Vector

CVSSv2 Vector

AV:N/AC:L/Au:N/C:P/I:N/A:N

Solution Type

Solution Type

Vendor Patch

Created

Created

1 year ago

Modified

Modified

1 year ago

Summary

Apache HTTP Server is prone to a directory traversal and a possible remote code execution (RCE) vulnerability.

Insight

Insight

An attacker could use a path traversal attack to map URLs to files outside the expected document root. If files outside of the document root are not protected by 'require all denied' these requests can succeed. Additionally this flaw could leak the source of interpreted files like CGI scripts. Note: If 'mod_cgi' is enabled this flaw can be also be used by an attacker to achieve remote code execution (RCE).

Affected Software

Affected Software

Apache HTTP Server version 2.4.49.

Detection Method

Detection Method

Sends multiple crafted HTTP GET/POST requests and checks the responses.

Solution

Solution

Update to version 2.4.50 or later.

Common Vulnerabilities and Exposures (CVE)