Vulnerability Details

Apache HTTP Server Memory Access Vulnerability (Linux)

Published: 2019-10-18 14:09:33
CVE Author: NIST National Vulnerability Database

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:N/A:P

Detection Type:
Remote Banner Unreliable

Solution Type:
Vendor Patch

Summary:
Apache HTTP server is prone to a memory access vulnerability.

Technical Details:
Using fuzzed network input, the http/2 session handling could be made to read memory after being freed during connection shutdown.

Detection Method:
Checks if a vulnerable version is present on the target host.

Affected Versions:
Apache HTTP server version 2.4.18 to 2.4.39.

Recommendations:
Update to version 2.4.41 or later.

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2019-10082

CVE Analysis

https://www.mageni.net/cve/CVE-2019-10082

References:

https://httpd.apache.org/security/vulnerabilities_24.html

Severity
Medium
CVSS Score
6.4
Published
2019-10-18
Modified
2019-10-18
Category
Web Servers

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.