Apache Roller 'XML-RPC' Protocol XXE Vulnerability

Published: 2017-12-01 05:51:50
CVE Author: NIST National Vulnerability Database (NVD)

CVSS Base Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Detection Type:
Remote Banner

Summary:
The host is installed with Apache Roller and is prone to xml external entity vulnerability.

Detection Method:
Checks if a vulnerable version is present on the target host.

Technical Details:
The flaw is due to XML-RPC protocol support in Apache Roller.

Impact:
Successful exploitation will allow a remote attacker to conduct XML External Entity (XXE) attacks via unspecified vectors. This vulnerability exists even if XML-RPC is disabled via the Roller Admin Console.

Affected Versions:
Apache Roller 4.0.0 and 4.0.1, 5.0, 5.0.1 and 5.0.2, The unsupported Roller 3.1 release is also affected.

Recommendations:
Upgrade to Apache Roller 5.0.3 or later.

Solution Type:
Vendor Patch

NIST (National Institute of Standards and Technology) NVD (National Vulnerability Database)

https://nvd.nist.gov/vuln/detail/CVE-2014-0030

SecurityFocus Bugtraq ID:

https://www.securityfocus.com/bid/101230

References:

https://liftsecurity.io/advisories/Apache_Roller_XML-RPC_susceptible_to_XXE

Search
Severity
High
CVSS Score
7.5

You never have to pay for a vulnerability scanning and management software again.

Tired of paying a subscription 'per asset' or 'per IP'? Well you can officially cancel your current subscription. Mageni provides a free, open source and enterprise-ready vulnerability scanning and management platform which helps you to find, prioritize, remediate and manage your vulnerabilities. It is free and always will be.